WHY does my 30A FUSE Keep blowing??? - Kawasaki ATV Forum
Kawasaki Brute Force/Prairie/Bayou Kawasaki's strong and reliable utility ATVs

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-04-2011, 08:10 PM Thread Starter
J D
Member
Feedback Score: 0 reviews
 
Join Date: Jan 2011
Location: Letellier Manitoba Canada
Posts: 65
WHY does my 30A FUSE Keep blowing???

I have a 2005 650SRA and I was driving along and bam! Everything went dead! I dragged it home and discovered that the 30A fuse in the starter solenoid is blown. So I put a new one and turned the Key bam another one. What is going on???
J D is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-05-2011, 07:39 PM
Junior Member
Feedback Score: 0 reviews
 
KAllan90's Avatar
 
Join Date: Jul 2010
Location: Winnipeg
Posts: 17
Check the connections at the starter, It could be that the main power is touching ground maybe. If all your connections are good and thats the only thing on the circuit I would say the starter is shorted.

09 Kawasaki Brute Force 750
2" Xtreme Lift Kit
1.5" Wheel Spacers
K&N Air Filter
RT 25 Warn Winch
Extreme Snorkels Kit
Gorilla Axle Rear Axles
12" ITP SS212 Black Alloy
27"x9"x12" and 27"x11"x12" Maxxis Zillas
KAllan90 is offline  
post #3 of 4 Old 02-07-2011, 04:50 AM
Premium Member
Feedback Score: 1 reviews
 
Join Date: Nov 2004
Location: Nova Scotia, Canada
Posts: 3,481
Is it the main fuse or a fuse for the starter......I thought there was only one 30amp fuse. Do you have heated grips or heated visor plug? They will often short out and cause this. The best thing to do is to start unplugging things until you find out what circuit is popping the fuse then trace the wires in that circuit. Its a very good chance its a pinched wire or one rubbing on the frame

Green 2004 Vforce
2002 650 Prairie
riverkid is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 02-07-2011, 09:13 AM Thread Starter
J D
Member
Feedback Score: 0 reviews
 
Join Date: Jan 2011
Location: Letellier Manitoba Canada
Posts: 65
No heated grips or anything. As far as I know there is only one 30A. It does look like I have a short. (I hate chasing wires!)
J D is offline  
Reply

  Lower Navigation
Go Back   Kawasaki ATV Forum > Kawasaki ATV Performance / Maintenance / Technical > Kawasaki Brute Force/Prairie/Bayou

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Search tags for this page
2002 atv keeps blowing fuse
,

2002 kawasaki 250 main fuse blowing

,
30a fuse keeps blowing 2004 kawasaki 250
,

arctic cat atv 700 30 amp fuse blowing

,
brute force 750 blowing fuse
,

fuse keeps blowing on 2000 kawasaki bayou 300

,
honda 4 wheeler keeps blowing main fuse
,

kawasaki bayou blowing fuses

,
what causes a fuse to blow in a circuit on a 1987 kawasaki bayou 300
,
what causes fuse to continue to blow out on four wheeler
,
why does my power fuse keep blowing motorcycle
,
why is my 750 honda blowing fuses at the solenoid
,
yamaha four wheeler blowing fuses
Click on a term to search our sites for related topics.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
keep blowing main fuse? bruteforce650wi Kawasaki KFX450/KFX400 2 12-25-2010 02:24 PM
blowing fuse vtprairie03 Kawasaki Brute Force/Prairie/Bayou 38 09-11-2007 05:47 PM
Ignition key switch blowing 30 amp fuse instantly tom97zr2 Kawasaki KFX700 V-Force 2 03-12-2007 10:06 PM
30 amp fuse under seat keeps blowing tcat1000 Kawasaki KFX700 V-Force 18 12-24-2006 10:18 AM
Keep blowing fan fuse... Licken2 Kawasaki Brute Force/Prairie/Bayou 3 08-15-2004 10:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome