prairie 650 4X4 trouble - Kawasaki ATV Forum
Kawasaki Brute Force/Prairie/Bayou Kawasaki's strong and reliable utility ATVs

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-26-2005, 02:41 PM Thread Starter
Senior Member
Feedback Score: 0 reviews
 
Join Date: Jun 2005
Posts: 144
I have an 03 650 P and it is stuck in 4 wheel drive. The dash says 2wd even when the switch is in 4wd. I think it is an electrical problem. There is no bumping or grinding noises coming from the front end and the machine turns normal for 4wd. When I notice the 2wd on the dash, I had been going through water, nothing high enough to damage anything, but I know I didn't do anything to hurt it mechanically. Is is possible that something got wet? Any suggestions on where to start trouble shooting.
detes55 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-26-2005, 03:49 PM
Premium Member
Feedback Score: 5 reviews
 
vtprairie03's Avatar
 
Join Date: May 2003
Location: lawrence county, ohio
Posts: 6,513
i had something similiar happen to mine. make sure that the 2wd/4wd switch is making contact. the rubber around the switch will dryrot and let moisture in corroding your connection. take the switch apart and clean it up good with contact cleaner and sqirt some dielectric grease on it. it fixed mine for about 3 months but the oxidation was so bad i had to just replace the switch. its only about 30bucks so not bad. im not saying thats what it is but its somewhere to start looking, plus its probably good to clean it up anyway from time to time.

FST 730
LTE DUALS
BILLET GAS CAP
BILLET SHIFTER
FLEXX BARS
ROX RISERS
ACEWELL TACH
DYNA CDI
ELKA SUSPENSION
INTERCOOLER SYSTEM


2007 kfx 90
120cc powroll bbk
cam'd
two brothers full exhaust
ac racing nerfs
rath racing front and rear bumper
jb racing +2 a arms



previous motors..

fst 765-stage 3 cams-full porting-lte duals
amr 800-ported big valve heads-x3 cams- lte duals..
vtprairie03 is offline  
post #3 of 4 Old 07-28-2005, 03:42 AM
Junior Member
Feedback Score: 0 reviews
 
Join Date: Jun 2004
Posts: 16
I had a bad switch on ours too. Was stuck in 2wd wouldn't switch to 4wd for anything, display didn't change either though. New switch took care of the problem.
squirrel is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 07-28-2005, 11:52 AM Thread Starter
Senior Member
Feedback Score: 0 reviews
 
Join Date: Jun 2005
Posts: 144
I traced all the wires and made sure all the connections were good, only to find out that for some reason the fuse for the KBEC was only letting 5 to 6 volts flow through and not 12. Two dealer ships told me that the 4X4 connection did not have a fuse. LIARS

After replacing that fuse the 4X4 worked fine. So the acturator must run off the same power as the KBEC controller. I don't know why the KBEC kept working on that low of voltage.

Thought I'd post this in case any one else comes across the same problem.
detes55 is offline  
Reply

  Lower Navigation
Go Back   Kawasaki ATV Forum > Kawasaki ATV Performance / Maintenance / Technical > Kawasaki Brute Force/Prairie/Bayou

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Search tags for this page

2003 kawasaki prairie 650

,

2003 kawasaki prairie 650 4x4 problems

,
2003 kawasaki prairie 650 4x4 switch
,
650 prarie kawasaki teryx 4wd switch
,
kawasaki 650 fourwheeler stuck in low
,

kawasaki prairie 650 4x4 not working

,

kawasaki prairie 650 4x4 problems

,
kawasaki prairie 650 4x4 switch
,

kawasaki prairie 650 4x4 troubleshooting

,
kawasaki prairie 650 stuck in 4x4
,
kawasaki prarie 650 stuck in 4wd
,
prairie 650 4x4 not working
,
prairie 650 stuck in 4x4
Click on a term to search our sites for related topics.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cam Trouble 450Duner Kawasaki KFX450/KFX400 9 05-16-2008 11:11 PM
having trouble please help crazyorange Kawasaki KFX700 V-Force 25 06-25-2007 11:15 PM
Have some trouble.. any HELP??? cole2676 Kawasaki KFX700 V-Force 15 03-27-2007 05:59 PM
ktm in trouble again bartlettracing Kawasaki KFX700 V-Force 4 01-09-2005 08:40 AM
Have some trouble.. any HELP??? cole2676 For Sale 0 12-31-1969 07:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome