2003 Prairie 360 4x4 in Limp mode - Kawasaki ATV Forum
Kawasaki Brute Force/Prairie/Bayou Kawasaki's strong and reliable utility ATVs

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-13-2019, 08:26 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Join Date: May 2019
Posts: 1
2003 Prairie 360 4x4 in Limp mode

I just got a 2003 Kawasaki prairie 360 and it has no power to it. It'll crank and run from the pull start but the electrical systems are messed up. The belt light keeps flashing and I've found that it's probably caused by it being in limp mode, I'm unsure how to take it out of limp mode or if it can be taken out of limp mode without the ignition switch working. It'll only go up to about 10mph right right and backfires really bad if you press the throttle fully. Any help would be great
ImprobableTrexx is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Kawasaki ATV Forum > Kawasaki ATV Performance / Maintenance / Technical > Kawasaki Brute Force/Prairie/Bayou

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with my 2003 Prairie tprman Kawasaki Brute Force/Prairie/Bayou 15 09-21-2016 10:59 PM
CDI swap in limp mode Gusgua1 Kawasaki Brute Force/Prairie/Bayou 2 08-23-2016 11:44 AM
2003 prairie 650 only spark once alexdzyak2007 Kawasaki Brute Force/Prairie/Bayou 7 04-21-2015 07:11 PM
04 Prairie 700 Belt Alarm/Limp mode wont reset! Skxawng Kawasaki Brute Force/Prairie/Bayou 2 10-22-2014 07:56 AM
Limp mode help! adurham Kawasaki Brute Force/Prairie/Bayou 30 10-11-2014 09:09 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome