Hesitation when first applying pressure on gas pedal - Kawasaki ATV Forum
Kawasaki Mule Discussions for the Kawasaki Mule UTV (Kawasaki Mule Forum)

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 05-09-2019, 03:41 AM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Join Date: Apr 2019
Posts: 21
Hesitation when first applying pressure on gas pedal

Since new the PRO FX has had a notable delay in response between my initially pressing down on the gas pedal and the clutch engaging the engine. This is not a problem on flat surfaces, but when starting on a steep incline I find I have to either keep the parking brake engaged or use my left foot on the brake while giving it gas or the Mule will roll a significant distance. Is this an inherent characteristic of how the clutch engages or is there an adjustment I can make to remedy it?
PETDOC is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-09-2019, 06:30 AM
Senior Member
Feedback Score: 0 reviews
 
Join Date: Jan 2017
Posts: 118
Yep. Always bugged me, so I did the clutch spring kit and it's gone.

https://www.kawieriders.com/forum/ka...lutch-kit.html
defenestrator is offline  
post #3 of 7 Old 05-10-2019, 04:47 AM
Senior Member
Feedback Score: 0 reviews
 
Join Date: Jan 2011
Location: Use to be Texas, now Southern Illinois
Posts: 245
Quote:
Originally Posted by defenestrator View Post
Yep. Always bugged me, so I did the clutch spring kit and it's gone.

https://www.kawieriders.com/forum/ka...lutch-kit.html
What size tires do you have and which color spring did you use?
jcummins is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 05-10-2019, 06:34 AM
Senior Member
Feedback Score: 0 reviews
 
Join Date: Jan 2017
Posts: 118
I'm still running 26" tires. I won't go above 27". I used Yellow for Primary clutch, and Pink for Secondary. I believe if you are running 28"+, there is another color (perhaps white?) that you run. I don't quite remember now. I talked with EPI and they told me which to use for my tire size.
defenestrator is offline  
post #5 of 7 Old 05-15-2019, 05:58 PM
Junior Member
Feedback Score: 0 reviews
 
Join Date: Nov 2018
Posts: 10
Quote:
Originally Posted by defenestrator View Post
I'm still running 26" tires. I won't go above 27". I used Yellow for Primary clutch, and Pink for Secondary. I believe if you are running 28"+, there is another color (perhaps white?) that you run. I don't quite remember now. I talked with EPI and they told me which to use for my tire size.


its the opposite of what is said above- EPI says white spring for up to 27" tires, pink spring for 28" and up


if you are running 28"+, there is another color (pink)
steven liebchen is offline  
post #6 of 7 Old 05-16-2019, 06:34 AM
Senior Member
Feedback Score: 0 reviews
 
Join Date: Jan 2017
Posts: 118
Thanks for this. I couldn't remember.
defenestrator is offline  
post #7 of 7 Old 05-16-2019, 11:06 AM
Junior Member
Feedback Score: 0 reviews
 
Join Date: Nov 2018
Posts: 10
Quote:
Originally Posted by defenestrator View Post
Thanks for this. I couldn't remember.
sure thing, we learned that by having to put them each in!
steven liebchen is offline  
Reply

  Lower Navigation
Go Back   Kawasaki ATV Forum > Kawasaki ATV Performance / Maintenance / Technical > Kawasaki Mule

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brute Cooling System keeping pressure Lineman052 Kawasaki Brute Force/Prairie/Bayou 11 08-26-2017 10:54 AM
Turbo Teardown Camo Member Pictures & Movies 187 03-15-2012 04:56 PM
Tire pressure.. what a joke! screamin96 Club Kawie 9 10-17-2011 05:14 PM
Fuel pump pressure LAVRx Kawasaki Brute Force/Prairie/Bayou 6 11-02-2009 04:33 AM
FPS cam testing update Dynoray Kawasaki KFX700 V-Force 439 11-21-2007 10:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome