Kawasaki ATV Forum banner

acceleration

  1. Bayou 300 carb problem-bogging and high idle

    Kawasaki Brute Force/Prairie/Bayou
    My Bayou 300 had been running great for a long time. In prep for taking it to the mountains this summer, I took the carb of to see what size jet it has. While I had it off, I sprayed it with carb cleaner but didn't disassemble anything other than the float bowl and main jet. After...
  2. 2006 Brute Force 650i problem.

    Kawasaki Brute Force/Prairie/Bayou
    Hey guys, I'm having an issue with my Brute. I start it and it idles fine. I put it in gear and press the throttle and it begins bogging or stuttering. Is there something I should look for? This machine has ran fine for me all winter. Please note that I am not too mechanically inclined so if...
  3. 09 brute 750 acceleration issues

    Kawasaki Brute Force/Prairie/Bayou
    I have a 2009 Brute Force 750. When I first got it, I was amazed at the power it had. I could hit 65 MPH no problem. Recently, it seems to not have the power it had before and it will only go about 51 MPH at the most. It feels fine up to about 10 MPH then it just feels very lathargic. I was...
  4. Brute Force acceleration problems

    Kawasaki Brute Force/Prairie/Bayou
    hey, whats up? i am NOT mechanically inclined in any way, so bear with me. I have a 2007 Brute Force 750, and i have been having problems with it when accelerating. it seems that a majority of the time when i start to push the throttle, the machine acts like it is bogging down and instead of...
Top