Kawasaki ATV Forum banner

bogging

  1. Kawasaki KFX450/KFX400
    Hi all I have a 2012 KFX450R, it runs good til it gets to 4th and 5th gear. It just starts bogging down and backfiring. It runs good in 1st 2nd and 3rd gear. The only thing aftermarket on it is a Yoshi pipe. I have been trying to figure this problem out for the past 2 months. I have put a new...
  2. Everything Else
    Prairie 700...around 07 model, by flooring the throttle its takes about 2-4 seconds of acceleration and it boggs down, granted its 6-9k ft lake tahoe riding, switched to premium fuel, still boggs, caught a previous post about a dirty throttle body....help mates...!
  3. Kawasaki Brute Force/Prairie/Bayou
    i am having a serious issue here guys and I need help please. I have a Kawasaki bayou 220 that I bought from a guy. ever since I bought it its ran like shit. I can crank it up and it will turn on just fine and idle good, I give it throttle and start trying to go and it bogs down it doesn't die...
  4. Kawasaki Brute Force/Prairie/Bayou
    My Bayou 300 had been running great for a long time. In prep for taking it to the mountains this summer, I took the carb of to see what size jet it has. While I had it off, I sprayed it with carb cleaner but didn't disassemble anything other than the float bowl and main jet. After...
  5. Kawasaki Brute Force/Prairie/Bayou
    Hey guys, I'm having an issue with my Brute. I start it and it idles fine. I put it in gear and press the throttle and it begins bogging or stuttering. Is there something I should look for? This machine has ran fine for me all winter. Please note that I am not too mechanically inclined so if...
  6. Kawasaki Brute Force/Prairie/Bayou
    Hey guys new to the forum and already hoping to get help with my 2006 Brute. Here's the back story, bought the bike used, but it ran great. Noticed a rattle in engine, took it to a shop and had timing chains put in and valves adjusted. Finally go to pick it up and it sounds great. Get on to...
  7. Kawasaki Brute Force/Prairie/Bayou
    okay, here's the scenario... My buddy has a 2007 brute force 750 STOCK... it had set awhile and his brother gave it to him to fix... It will start up just fine and idle like nothings wrong.. but when you hit the throttle, it bogs down and you have to pepper the gas to get it to rev up and if at...
Top