Kawasaki ATV Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-17 of 111 Results
  1. Kawasaki Brute Force/Prairie/Bayou
    New to the forum and first Kawasaki. Thanks for the help in advance. I have a 2019 Brute force 750 that will idle but when given any bit of throttle it dies. Before it started this problem it was a dog and wouldn’t go over 30mph. The bike has around 4000 miles and its Here is what I have done...
  2. Kawasaki Brute Force/Prairie/Bayou
    Hey guys I bought my 750 Kawasaki brute force 2006 with the buss connector already cut and wires just twisted and taped so I would have to pull the main fuse to shut off the quad so I went in to do it properly but I can't figure out how the wires are suppose to go, there are 4 black wires 4...
  3. Kawasaki Brute Force/Prairie/Bayou
    2008 brute force 750 is popping 30 amp main fuse soon as i turn the key on any thoughts? Bare wire?
  4. Kawasaki Brute Force/Prairie/Bayou
    So I did the belt light reset on my 650 brute force 08 and now I have no headlights and no power to the starter. I tried resetting it again, checked fuses and still nothing. I’ve read about similar issues but no fixes. All of the connectors are back in place, do you think it’s coincidence that...
  5. Kawasaki Brute Force/Prairie/Bayou
    Just got a new Brute Force 300 with 13 miles on it. Trying to give it full power, it seemed to only go about 15mph top speed on dirt and the street. We adjusted the Rev limiter screw and nothing happened, any ideas on what the issue may be?
  6. Kawasaki Brute Force/Prairie/Bayou
    I recently purchased a 2006 Brute Force 750 (carbed) and is giving me some problems. Only mods it has is dynatek cdi and hmf slip on exhaust. It takes a little to crank up and i have to choke, but it idles fine. On take off it is very slow. Wont go over 45-50mph, and takes a while to get there...
  7. Kawasaki Brute Force/Prairie/Bayou
    can someone help me? had my battery disconnected so i recently reconnected it. accidentally put negative wire to positive on the battery and positive wire to negative on the battery with my key on. blew my solenoid fuse, so i replaced that. idles fine but when i put it on the road the atv won’t...
  8. Kawasaki KFX700 V-Force
    Please search and join the Facebook group kawie riders
  9. Kawasaki Brute Force/Prairie/Bayou
    Bought this ATV about 3 days ago got it for 1200 dollars because it needs a muffler and it WAS STUCK IN 4x4 The Issue is the this I tried removing the actuator but for some reason it just wouldn’t come out easy ! I then just screwed it back on and decided to take the actuator cap off so I...
  10. Kawasaki Brute Force/Prairie/Bayou
    Hey everyone I’m semi mechanically inclined and I’m working on a friends 2008 Kawasaki brute force 750 efi so this bike literally has 17 hours and 84 miles I’ll repeat myself 17 hours so my problem is that I have no spark so first thing I did is test the coils they were very hot after cranking...
  11. Kawasaki Brute Force/Prairie/Bayou
    Hey guys, Got a question been searching for weeks can’t find anything on this. I got a 2004Prairie 360 4x4 the plain bearing in the left side crankcase seizes to the crank bearing was able to save the crank every measures out within specs. But having problems finding the plain bearing does...
  12. General Kawasaki ATV Discussions
    So here's the situation. I was out for the first cruise of the year last week. All was going good and i was on my way back to my house and when i was heading down the road holding the throttle steady and the wheeler acted like it was losing power for a few seconds. It came out of it quickly and...
  13. Kawasaki KFX700 V-Force
    Can any one help out? I left the ignition on overnight which apparently caused a problem other than a dead battery. I charged the battery and jump started the quad it started but I noticed that the fuel gauge did not read any levels and I filled tank, no other readings on display not even 4wd...
  14. Kawasaki Brute Force/Prairie/Bayou
    My 2009 750 brute force lost spark and i'm lost at what to do next. Ive check the crank sensor key, that seemed fine i checked to ensure i was getting 12v to the yellow and red wire on my coil. chased the wires up to the harness and i seem to be getting power from my crank sensor to my cdi but...
  15. New Member Introductions
    My 2009 750 brute force lost spark and i'm lost at what to do next. Ive check the crank sensor key, that seemed fine i checked to ensure i was getting 12v to the yellow and red wire on my coil. chased the wires up to the harness and i seem to be getting power from my crank sensor to my cdi but...
  16. Kawasaki Brute Force/Prairie/Bayou
    Hi I have a 2007 brute force 650 not the i. The boot over the rear drive shaft is leaking oil through a small hole. I want to replace the boot but not sure how to do it. It looks like I remove the swing arm and the rear drive shaft but I want to know if this is the correct process here are my...
  17. Kawasaki Brute Force/Prairie/Bayou
    Been a while since I visited here let alone posted, lots of the older tech advisors seem to have moved on but here's hoping.... I ingested some mud and crap running a mud drag in a grass drag setup 820 SRA, my bad. So, now I am rebuilding it. It's a TRP 820, LSP flow benched heads with oversized...
1-17 of 111 Results
Top