Kawasaki ATV Forum banner

hot

  1. Kawasaki KFX450/KFX400
    ok guys im in a pickle lol after months of talking my friend into buying a quad he finally goes for it and picks up a '05 kfx 400 claiming to have the bore kit to a 440 and a slip on exhaust. i believe that's all for $1800.. runs like a champ, i drive a 250 (ill leave out the model lol) and i...
  2. Kawasaki Brute Force/Prairie/Bayou
    My buddy swamped his bike last year, its a 07 prairie 650, he couldn't get it running, the bike felt seized but after we took top end apart it was good, spins over great, so we put it back together but when it gets up to temp it starts to smoke bad, so we tore it apart again and put new rings in...
  3. Kawasaki Brute Force/Prairie/Bayou
    I have searched for a similar thread but have not seen any problems as specific as mine; I apologize if I missed a sticky for such a problem. My 2009 Brute Force 750i is running really strangely once it gets really hot, like after a long hill climb or ploughing snow or mudding. Up to this...
  4. Kawasaki Brute Force/Prairie/Bayou
    Hey guys just looking for some input. This weekend I was trail riding in the mountains, when My temp light came on. My rad is spotless, and I can pour the water through it. But my temp jumps to 250, I shut it down and keep the fan to it for less than five mins. As soon as I Turn it back on temp...
  5. Kawasaki KFX450/KFX400
    I want to set up hot start reverse lever on my kfx400 but I don't know what cable to use for it. Do you use stock reverse cable or is there a specific cable to use?
Top