Kawasaki ATV Forum banner
missing
1-5 of 5 Results
  1. Kawasaki Brute Force/Prairie/Bayou
    Picked up a 03 Prairie 360 about a month ago to go with my '96 Honda TRX 300. The quad had been sitting for over a year when I got it, so I pulled/drained the tank and pulled the carb/cleaned it according to the factory service manual. Idle is rough/non existent unless I adjust the throttle...
  2. Kawasaki Brute Force/Prairie/Bayou
    I have a 2007 brute force 750 with a hmf pipe, k&n air filter, and moose racing digital ignition. It skips all throughout the mid range and high.. It is jetted for the pipe only so I tried a stock air filter on it and it made it worse.. Then i put the k&n back on and it stayed bad.. Its almost...
  3. Kawasaki Brute Force/Prairie/Bayou
    Hey guys new to the forum and already hoping to get help with my 2006 Brute. Here's the back story, bought the bike used, but it ran great. Noticed a rattle in engine, took it to a shop and had timing chains put in and valves adjusted. Finally go to pick it up and it sounds great. Get on to...
  4. Kawasaki Brute Force/Prairie/Bayou
    I recently purchased a 2013 Prairie 360. It cuts out or misses when I give it gas during the warm up. I saw in the forum that people refer to the Prairie 360 as cold natured, but did not see anything with respect to cutting out. Has anyone else had this problem? Is it something to be concerned...
  5. Kawasaki KFX700 V-Force
    Ok, gotta put you guys to work. Dual pro circuits, K&N, 12 hole mod Before, the bike would bog down and miss out when taking off under load from idle. I had changed the mains to 82/85 but hadn't done anything to the pilots/shims yet. I thought the problems I was having were because I hadn't...
1-5 of 5 Results
Top