Kawasaki ATV Forum banner

no power

  1. Kawasaki Brute Force/Prairie/Bayou
    Hi All, New to the site and have read most forums regarding my issue. I have a 2002 Prairie that doesnt want to go past 15mph and has no power to get over little bumps into a garage. I have checked the Drive belt Switch = on. I have a new battery. I cleaned the carbs (one jet was simi...
  2. Kawasaki Brute Force/Prairie/Bayou
    Hello. New to this forum but love forums in general. Just bought a 1990 Bayou 220 and it doesn't run. Got it for almost nothing and the engine is not seized. I can turn it over with the pull cord. Threw in a new battery today but I get nothing. No lights, no sounds, nothing at all. Any tips...
  3. Kawasaki KFX700 V-Force
    Need help. I have a kfx 700 with no power. will not stand up. Drive able in low rpm's ( very slow) it has to be valves. backfires LIKE crazy. it did run fine sometimes in till u go to fast on top end for to long. it messes up no power. it might go back to normal. but it didn't this time.we...
  4. Kawasaki Brute Force/Prairie/Bayou
    I NEED HELP. My dad just gave me a 1986 Kawasaki Bayou 300 2x4 with differential. It always had a hard time starting in the cold, but never electrical issues. My dad said he bought a new battery and at first it started, then he was having to jiggle the key, and now nothing. No neutral light...
  5. Kawasaki Brute Force/Prairie/Bayou
    I have a 1988 Bayou 300 2WD that runs fine at idle and runs fine once get above 1/4 throttle. As it warms up it does better and better but never running like it should. The problem is always at about 1/4 throttle, it spits sputters and backfires until I get rpms higher then runs fine whether...
Top