Kawasaki ATV Forum banner

stalls

  1. New Member Introductions
    I have a 2002 Mule 3010 gas. Recently, it began suddenly stalling after operating a few minutes. If you let it sit it starts again, runs for awhile, and stalls again. Replaced fuel pump and fuel relay. No help. Thought it might be a plugged fuel vent, but there is no vacuum sound when the fuel...
  2. Kawasaki Mule
    Hi, I am new to this forum. I have a 2006 mule 610 with about 200 hours on it. After it gets hot from use it will start to run rough and then stall. I have to choke it and then unchoke it to get it started again. but until it cools off it will keep doing this. Someone suggested that it may...
  3. Kawasaki Brute Force/Prairie/Bayou
    Just picked up this 2004 Prairie, it will start up but have to keep choke on to idle even after warm up, it runs out great but when I come to a stop, it will cut off, then have to choke it to start up again. I removed gas and added new, changed oil, filter and plug. Just curious where I should...
  4. Everything Else
    last week it was running like shit and sputtering then i found out the plug that goes on the ignition coil was loose. i fix it then it was running really good, it sat for a week and i started it up today it started first pull but whenever i push the throttle just a little bit at stops running. i...
  5. Kawasaki KFX700 V-Force
    Im confused and baffled at this problem! It was sitting for like 2yrs, when I got it, but I did hear it running. I never rode just took it home and had the carbs cleaned and jetted, got new fuel filter and new pump because the other pump was bad, air filter, fresh antifreeze, oil and filter...
  6. Everything Else
    Hi all, I just bought an 06 KFX 50 for my son a few days ago. It fired right up when we checked it out, but when I got home I realised the choke had been on the whole time we were speaking with the sellers. After we got home and I started it up, it would stall everytime I tried to switch the...
Top