Kawasaki ATV Forum banner

throttle

  1. Kawasaki Brute Force/Prairie/Bayou
    Hey guys, I'm having an issue with my Brute. I start it and it idles fine. I put it in gear and press the throttle and it begins bogging or stuttering. Is there something I should look for? This machine has ran fine for me all winter. Please note that I am not too mechanically inclined so if...
  2. Kawasaki Brute Force/Prairie/Bayou
    I have an 04 prairie 700 and Ive started to notice a lag if you press the throttle down all the way. Its fine if you slowly rev up, but when you gun it there is a delay in response. Any ideas on what could be causing the lag? Idle is fine. I am new to this site, any help is appreciated.
  3. Kawasaki KFX450/KFX400
    So my 06 kfx400 has never given me a bit of trouble, over the weekend i was riding some local trails and about an hour into it cut out on a hill climb. I thought i fouled a plug so i had to run full choke and couldnt give it ANY throttle or it would die. i limped her home, replaced the plug and...
  4. Kawasaki KFX700 V-Force
    Hi......I've seen some posts about replacing the KFX700 throttle/cable and I'm currently watching one on Ebay...thanx to another member for the link :D Can anyone who has made this change in the throttle comment on this thread and let me know how it turned out and how much of a difference it...
  5. Kawasaki Brute Force/Prairie/Bayou
    I have a 1988 Bayou 300 2WD that runs fine at idle and runs fine once get above 1/4 throttle. As it warms up it does better and better but never running like it should. The problem is always at about 1/4 throttle, it spits sputters and backfires until I get rpms higher then runs fine whether...
  6. Kawasaki Brute Force/Prairie/Bayou
    Hey guys, My 400 Bayou 1996 is having throttle issues. It starts and idles no problem. However, as soon as I give it gas it wants to choke out and die. I have replaced the oil and air filtler (since this happened) still no luck. Any suggestions on what it could be? I have tried leaving it...
  7. Kawasaki Brute Force/Prairie/Bayou
    My 05 BF 750 will not rev up no matter what gear. It is like the limiter is kicking in at about 1/4 throttle and then it spits and sputters. Runs and idles fine and can go about 20MPH still. Has a new belt and the the belt sensor was reset. Been told that it may be the actuator on the belt case...
Top