Kawasaki ATV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey I’m new to the brute force but I just installed an 840 kit running stock heads and cams with a moose power module and hmf exhaust I ran it last weekend and it drove fine but bogged at full throttle and didn’t have half the power I was expecting I took the carbs apart and found stock jetting which I didn’t expect since I bought it with the exhaust and power module my question is what size jets should I be running and could this be why I was bogging down at full throttle and had backfiring when cold after it’s warmed up it idles fine but seriously lacking in power
 

·
Registered
Joined
·
641 Posts
840 you will be up in the 170's to 180's on jets
depending on elevation and what the engine likes.
2 shims under each needle, 42 pilots, hole drilled in slide , running 2 - 2" snorkels and muzzy super pro dual exhaust
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
840 you will be up in the 170's to 180's on jets
depending on elevation and what the engine likes.
2 shims under each needle, 42 pilots, hole drilled in slide , running 2 - 2" snorkels and muzzy super pro dual exhaust
Where are you finding the jets and pilots any recommendations. I just got the shims today and are you running the same size jets in front and rear carbs
 

·
Registered
Joined
·
641 Posts
we have 182 front
185 rear
jetsrus.com
sudco.com
where we got our jets
1 ordered 1 of each size from 170-190
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Are you still doing 2 1/2 turn on mixture screws. Also the 4 screws that hold the cover for the Diaphragm 1 was stripped have you replaced these because I can’t find them anywhere and wasn’t sure if I could just make a spacer for Allen head screws to swap them all out
 

·
Registered
Joined
·
166 Posts
Hey I’m new to the brute force but I just installed an 840 kit running stock heads and cams with a moose power module and hmf exhaust I ran it last weekend and it drove fine but bogged at full throttle and didn’t have half the power I was expecting I took the carbs apart and found stock jetting which I didn’t expect since I bought it with the exhaust and power module my question is what size jets should I be running and could this be why I was bogging down at full throttle and had backfiring when cold after it’s warmed up it idles fine but seriously lacking in power
yes, jet it properly.

do you have a foam filter? that would help, and then go bigger jets.
how big? start testing by half sizes. (easiest way, but is time consuming)

if you get a complete jet kit for the specific ride, it will come with the correct range.
 
1 - 8 of 8 Posts
Top