Kawasaki ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I have a 2007 Priarie 360 4X4, it seems periodically that when I put it into drive the the belts start to whine. Is this an indication that they need to be replaced? It doesn't do it loud or even once I start moving only when in drive while at idle/in place. If they are in need of replacing....are they a nightmare to replace. I think I remember looking at the belt price and they were around 90.00 to 100.00 bucks. Any help would be appreciated, this is a newly bought Kawi for me, it didn't have much use from the prior owner and was bought new in 08. Thanks for the help!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Nobody ever had/has this problem? I know I am new here and maybe should be hazed but if you help me, I will take my beating/hazing like a man.. Lol
 

·
Registered
Joined
·
294 Posts
belt noise

my belt squeels when i put it in gear. mine is tight that is why it does it.if your belt does not slip id let it be.it is easy to change belts but you need a primary puller.i got mine from epi for i think 35 bucks. its probably a sticky on here somewhere about changeing the belt
 

·
Premium Member
Joined
·
23,817 Posts
is it whining or squealing?
 

·
Super Moderator
Joined
·
12,555 Posts
If it lightly squeals at an idle, in gear, then it means the belt is on the tight side, which is good. If it actually creeps ahead while in gear at an idle, then it's too tight.
I assume it's been like this since you bought it, since the belt won't "get tight" over time.
 
1 - 5 of 5 Posts
Top