Kawasaki ATV Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,998 Posts
Discussion Starter #1 (Edited)
As of now John is hard at work and I copied and pasted what he wrote in the other thread here for the update. AMR 800, XX cams, Muzzy Pro, Power Commander PCIII, VFORCEJOHN Stage 3 spidermod clutch with Maroon Spring, EHS air box lid, and a bunch of little stuff John did to make it run better...


...still going. with the EHS lid, injector duty is 90%. I have larger injectors. (thank god I don't have to order them :lol:) when things cool down, I'll swap them. it's a good hour job.

so far it still stumbles out of the hole a/f is dead on perfect. something in the ECM is cutting back timing or something. I tried the vacuum canister on the map sensor. it helped low end a little but not a direct fix. I tried crossing the intakes. mini ms mod on the vacuum nipples under the intake flange. that did nothing. I also crossed the larger IAC sensor lines. that helped a little but still not enough to be consistant. That is this things main problem. getting a consistant run and keeping it there

I have 4 kawy map sensors, they all do the same thing. so it's nothing faulty. funny thing is, I can sit the map sensor on my lap with a longer vacuum signal hose to the head. blow in the sensor with just breath (like you are blowing out a candle) and it'll run better. a/f changes richer, but from 12.5-12.6 to 12.1-12.3 I can up the a/f with the pc3 to 12.1-12.3 and it runs worse. seems to like 12.5-12.8 range for max power.

Ignition module is on and timing is +10. maxxed out. past 7000 rpm I dial it back to 8 and then 6. runs the best like that.

pc3 fuel pump enrichener is on actually I dial back the fuel not enrichen it and power came up low end. so that's done

FI on these BBK bikes is a waste. if this thing was carbed. it'd be 68-70 rwhp easily. that motor is strong as hell.

If you roll on it at 20, power is 62 rwhp @ about 50 mph and keeps climbing . gun it out of the hole and something restricts it. You can immediatly hear it/feel it something happens, it only makes 57-59 rwhp and falls flat on mid-top.

with out the pc3. 42 rwhp. it won't even run just stumbles, but still blows 14.5 a/f

back to tinkering. it should be cool enough now to put the injectors in. I'm also going to flow skips stock injectors. I'd bet the rear injector flows less than the front. exhaust temps are near 80-100 degres higher. front runs 675 rear is 750-775 could be related to the bends of the muzzy pro. upping the cylinder split feature 5% will make them very close in temps.

and The new rings Glenn sent me are about the best I've ever had in one of these motors. there is ZERO blow by even holding it at 80 mph. not even so much as a puff of air or oil.

the 1 layer head gaskets are holding nicely, no issues there either.

back to work

John
Thank you Glenn at AMR and John at Interstate Motorsports. John has gone above and beyond for this build!!!
 

·
Premium Member
Joined
·
23,817 Posts
yeah I've heard the EFI Brutes are a bitch to get to really run when you start building them up
 

·
Premium Member
Joined
·
10,869 Posts
You are in good hands skip;)
Great work john.
 

·
Premium Member
Joined
·
16,646 Posts
Can you try a set of carbs on it?
If you can,it would tell you if it's an ignition problem or fuel problem.
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #5
You are in good hands skip;)
Great work john.
Honestly I can't say enough for John. Most people would have had me pay them and get it back so so. John has insisted time and time again to wait until he is done then he will take my money. Plus with him already letting me know he would pretty much he would be doing the tuning for free. I have done everything he's asked and is a great guy to deal with both business and friendship!!!

Can you try a set of carbs on it?
If you can,it would tell you if it's an ignition problem or fuel problem.
I don't have any carbs. Do you? Maybe John does. He is already doing the tuning for free what else can I ask for?

I think I will have to make some APPLE PIE for John!!! But after he's done working on my Brute Force:lol:
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #6
Update:

John has the other injectors and seem to lose some of the low end stumble is down and low end power is up. He also said it seems to be rich with 70% cycle duty so he is stepping it down to 60%. I will keep you updated as I get the info from John and I'm sure he will add stuff to that. He already did some stuff that I can't even explain because I don't know what he did...
 

·
Vendor
Joined
·
15,419 Posts
injectors worked larger and different spray pattern. map sensor mods worked, IAC sensor mod also worked. I can go over them later.

low end stumble is fairly well gone. id;e is high at 2000 rpm, so I have to turn that down. usually it is the other way around?? it's a bitch to do.

#'s are up above 63 already. at 60 mph, it's holding about 24hp more to the wheels than when it was stock with the pipe and controller at 46 rwhp.

and I still ain't done with it yet. neighbors are bitching about dynoing at 10:30.

oh well. tomorrow's another day. the motor's running great. over 70 runs already to 80 mph and not even a drop of oil. fan hardly even kicks on unless I'm doing alot of back to back runs.

John
 

·
Premium Member
Joined
·
23,817 Posts
not sure which rings you got, but I gotta agree....mine blows no oil what so ever
 

·
Vendor
Joined
·
15,419 Posts
these were the "special rings" we waited about a month to get them in from CP. this cyl is 87.75mm so 88mm rings don't really fit

Most don't blow oil either, but they still puff a little crank air out. this thing does nothing. usullly you'll even hear the puff when it idles. it's so minimal at idle.

these pistons are also gas ported, so that can be taken into account as well. your's prob are too.

John
 

·
Registered
Joined
·
477 Posts
Patiently waiting final numbers. Do you think the clutch is setup correctly for this setup or could it be improved? I still haven't found the setup my bike likes.
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #12
Awesome John!!! Sorry the neighbors started to Bitch. Are they family or not?:p I'm glad its working in your favor. I was thinking about missing the xmas party and coming up lastnight but the wife said that wasn't nice to do that. So I must say thank god I got free text messaging.... My buddy Jason said he might have to bring up his can ham some time to dyno....
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #13
It's Done!!!!
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #15
67.4 rwhp
 
1 - 16 of 16 Posts
Top