Kawasaki ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello I just joined the group here. I purchased an 09 750 brute in may and have been having heat issues on and off since I bought it. I must say though first off it has a custom cage built around the body with a full skidplate that starts about 3 or 4 inches below the bottom of the grille. I have wondered if that is most of my problems but praying not. Ok mods. I have boxed in the sides and bottom of the front of the radiator which has helped alil cruising down the road and almost completely stopped me worrying about mud in the radiator. Installed a higher flow 10" fan with manual switch override. Installed a 4"x10" plate style oil cooler in front of radiator. Temp gauge on top radiator hose of course. Checked that thermostat is properly operating, even did the 1/4 inch hole in it to help it get ahead of the heat. A highlifter fuel pump cleaned the fuel system at same time. Mimb 2" custom built snorkels. Just this week installed an msd fi tuner and full swamp xl exhaust. Still today took it out ran between 220 and 235. Riding trails or 50 down the black top. If the temp outside is under 80 I have no issues but anything over 90 I have to stop and let it cool down every now and then. I'll try to upload pics of the front of the bike tomorrow if I get off work before dark. Thank you
 

·
Registered
Joined
·
718 Posts
Welcome to the forum.

Wonder if that oil cooler is robbing the radiator oiling too much air? Have you ruled out error in the temperature gauge?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
The oil cooler has been along side of the new fan the most helpful. But I was thinkin the gauge too but I have had the temp light come on too and I'm on my 2nd gauge too mechanical of course. Also to see if my temps are right I forgot to mention my fan doesn't kick on till about 220 and my temp light comes on around 245. Does that sound right? I really think the fan should come on sooner which is why I installed an override.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Me and some friends are goin riding at Disney ok sunday one has a infrared thermo well take with and I'll be monitoring it with that as well
 

·
Registered
Joined
·
718 Posts
Me and some friends are goin riding at Disney ok sunday one has a infrared thermo well take with and I'll be monitoring it with that as well
That's what I was going to suggest next. I assume the radiator core is clean? Not certain on the temps the fan and light come on but sounds about right to me.
 

·
Registered
Joined
·
4,219 Posts
supposed to run 220-230, as long as you keep the rad clean i wouldnt worry
 
1 - 7 of 7 Posts
Top