Kawasaki ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
OK It's a 2005 P700 THE QUAD RUNS FINE and it has 140 hrs on it this has been flashing for the last 30 hours of so it will stop for a while when you turn the quad off then back on it wont come on right away but does come on. and noticed the noise that comes from the front of the CVT cover is a bit longer than the normal noise I think thats the KEBC ACTUATOR the weird thing is I never at any time have a problem getting the quad into 4 wheel drive I checked the manual and the flashing is in the interval of 1 sec on 2 wheel then 1 sec on 4 wheel indicator in the manual it says WITH the 1 sec interval its the ENGINE BRAKE ACTUATOR but i think its working fine in West Virginia going down hills the engine brake would work as follows going down the hill the engine brake would work for 5 to 10 seconds then free wheel I would have to blip the throttle and the engine brake would work ok again for 5 to 10 seconds I THINK THATS the way it works so how do you really prove its the engine brake actuator should I just take it appart and clean the gears and grease them what are your thoughts thank you in advance
 

·
Registered
Joined
·
787 Posts
When I took out my KEBC, you really couldn't tell I had done anything. My bike will still come to a stop without using brakes. Under about 5 mph, you will feel it freewheel a little bit, but like you said, blip the throttle and the engine brake is back. And it's probably just a problem with the magnets.
 

·
Premium Member
Joined
·
6,513 Posts
dg-6 module takes all the confusion and costly expenses out of the way... its a one time fix.. you never have to worry about that damn kebc again... best 90 bucks ive spent..... especially when a used kebc will run you alittle more then that and theres no guarantee its going to last....
 

·
Registered
Joined
·
787 Posts
dg-6 module takes all the confusion and costly expenses out of the way... its a one time fix.. you never have to worry about that damn kebc again... best 90 bucks ive spent..... especially when a used kebc will run you alittle more then that and theres no guarantee its going to last....
I spent $5 on a relay.
 

·
Registered
Joined
·
652 Posts
Sorry to bring this one back...but I'm sick of searching. I have my KEBC brake removed...I can switch between 2wd and 4wd...all is good...except for the 2wd/4wd flashing constantly. Where exactly does the relay wire into and does anyone have either some pics or a diagram....And I'm assuming its a 12vdc spdt relay.....Thanks!
 

·
Premium Member
Joined
·
6,513 Posts
jakedog, when you switch your bike from 2wd-4wd does it still switch on the dash or does it stay in one position all the time with your relay??? i thought when doing the relay switch it stayed in either 2wd or 4wd on the dash?
 

·
Registered
Joined
·
787 Posts
Nope when I switch it into 4wd it says "4wd". When in 2wd it says "2wd".

The only difference between it and the DG6 is, with the relay, it automatically says 4wd when switched, instead of when the 4wd actually engages. <--Understand that? It's kinda hard to explain.

And my relay is under my pod(for better protection from water/dirt), not under the seat. All the wires you have to splice are under the pod, as well as under the seat.
 
1 - 8 of 8 Posts
Top