Kawasaki ATV Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Good morning everyone,
I recently bought an 02 prairie 650 and I took it riding for the first time last weekend. got about 22 miles in to riding and the temp light started flashing. I hadn't hit any crazy mud or water but the radiator was completely covered in mud (front and back) it was so bad that the mud even damaged the fan blades. So I've spent a few hours searching here and on google for a radiator relocation kit. It turns out that the only relocation kits I can find are for Brute Forces, or something that was home made. So I guess my question is will a SRA Brute Force 650 relocation kit work on a Prairie 650?
 

·
Registered
Joined
·
245 Posts
If you hadn't hit any crazy mud or anything, I would be trying to figure out how so much mud got into the radiator that it caused it to overheat and damage the fan blades. Are all of the shrouds to protect the radiator still on the bike? Have you checked to be sure the cooling system is working and the temp switch and fan relay work properly?


Just seems like an odd scenario.....
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
yes all of the fenders/flairs are in place as well as the metal brush guard on the bumper. The trails were wet and muddy but I wouldn't constitute that as being any crazy mud, like I didn't take the machine through a mud bog. The fan does kick on and turn off on its own but, with out an actual temp gauge I cant judge weather or not its at the proper temperatures. the coolant levels were correct (radiator full, over flow tank full as well) it didn't puke any coolant out, and the temp light was only flashing. I am unsure if that just means its getting hot and it stays on when its actually over heating?
 

·
Registered
Joined
·
4,219 Posts
the side rad covers specifically have to be there, i have seen people leave them off to clean it but the air needs those and it keeps the mud out. would pull the rad out on any used bike i buy and clean the suspension rad fins and stuff, even if you have those covers you dont know how long it was since it was cleaned
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
the side rad covers specifically have to be there, i have seen people leave them off to clean it but the air needs those and it keeps the mud out. would pull the rad out on any used bike i buy and clean the suspension rad fins and stuff, even if you have those covers you dont know how long it was since it was cleaned
All of the fenders that are supposed to be there are there. in-fact I cant get the side skirts off since the screws are seized in place. I spent some time yesterday taking off what fenders I was able to get off and this thing doesn't look like it has been washed in years other than the previous owner just rinsing off what was easy enough to rinse. so for all I know the fan could have already been damaged and the radiator partially plugged and I just happened to plug it the rest of the way.
But on another note rubber down customs has told me that their radiator relocation kits for the Brute Force 650 SRA are the same as a prairie 650 incase any one else was curious.
 

·
Registered
Joined
·
4,219 Posts
should be the same kit, the one on the side that covers the rad and fan i only had a couple screws in so i could clean it easy. i take the fan off, pretty easy, simple green it and rinse with a garden hose a couple times.

wish it was that easy on my can am, might end up relocating mine just because its much tougher to get the fan
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
So an update and a question. I found a wild boar radiator relocation kit and radiator on craigslist for $150 the quad being parted out also has snorkles. it appears to be in decent shape aside from rust stains in the paint from the bolts. the question is it is off an 07 750 with IRS. I know people sell kits for SRA and IRS. what is the difference between the two? is it just the way it mounts? if I got the front rack with the kit would that make the kit work right with my 02 prairie, and is the snorkel kit similar or should I stay away from everything?
 

·
Registered
Joined
·
1 Posts
Good morning everyone,
I recently bought an 02 prairie 650 and I took it riding for the first time last weekend. got about 22 miles in to riding and the temp light started flashing. I hadn't hit any crazy mud or water but the radiator was completely covered in mud (front and back) it was so bad that the mud even damaged the fan blades. So I've spent a few hours searching here and on google for a radiator relocation kit. It turns out that the only relocation kits I can find are for Brute Forces, or something that was home made. So I guess my question is will a SRA Brute Force 650 relocation kit work on a Prairie 650?
I have one and been trying to find a radiator relocation kit too. Any suggestions?
 

·
Premium Member
Joined
·
10,218 Posts
I have a stock 05 Brute 650SRA radiator if any of you are just looking to add another instead of relocating your original.

Sent from my LM-G710VM using Tapatalk
 
1 - 9 of 9 Posts
Top