Kawasaki ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hey, the oil filter box on my 750 keeps filling with oil. Every few hours there will be so much oil in the filter box that it runs into the filter and smokes like hell. Used to only do this when I'd do a bunch of wheelies. Someone told me it was from a crank case breather?

I'm thinking that it's now so full of oil it siphons oil of there now? Or something?

Any ideas?

Thanks
Chris
 

·
Registered
Joined
·
1,413 Posts
Also, make sure you aren't overfilling it. I believe its not good to fill it up to the "full" mark. Only about halfway up the hatched mark area is enough. I'm sure someone can verify for me.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
Yeah that's what I normally do. Then I took it to the stealership and got them to change all the fluids. They over filled it, then it blew smoke after one wheelie. So I did my own oil change after that ride, about halfway in the hatch marks.

But it seems like it is still worse then before I took it into them.

I'm doing another fluid change right now and see if it helps any more this time.

It's also been backfireing like a bitch on decell. Buddy said he seen a big flame out the tail pipe too.

Just trying to see if all these problems are related. Using oil, oilly filter, backfires.
 

·
Registered
Joined
·
1,413 Posts
Might need to fatten up the low speed screws to get rid of the decel pop.
 
1 - 6 of 6 Posts
Top