Kawasaki ATV Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I have a service manual and i understand the process to reset the belt but i dont have the gray four prong plug can i just buy a new one and is it wired into somthing next to the black plug.
 

·
Premium Member
Joined
·
1,377 Posts
The Gray Plug should of been attached and next to the black plug under the seat. Your Dealer should beable to get another gray plug.
 

·
Registered
Joined
·
19 Posts
Hey quick ? for ya...I just had my 100 hr service done but i only have 97 hrs...i dont want to be out riding and my belt light come on i dont know how to reset it could you help i have a 08 650 also please help....i also have a moose power module Thanks
 

·
Registered
Joined
·
182 Posts
Hey quick ? for ya...I just had my 100 hr service done but i only have 97 hrs...i dont want to be out riding and my belt light come on i dont know how to reset it could you help i have a 08 650 also please help....i also have a moose power module Thanks

The dealer probably reset it for you, take note of your mileage and wait another 100.

Write this down, put it in a ziploc bag on/in the quad for future reference.
 

·
Premium Member
Joined
·
1,377 Posts
It is not a big deal if your Belt lite comes on during a ride nearing the 100 hr mark. Some come on just before 100 hrs, others later, the one on my 08 750 came on at 112 hrs. It doesn't do any harm if the belt lite comes on, it just stays on steady, a little nerve racking I guess to see the light on but it won't go into "limp Mode"with a steady Belt lite on. Either take the instructions with you and do the reset on the trail, it only takes about 5 minutes or take it in to the dealer, they will reset it for you for free.
 

·
Registered
Joined
·
259 Posts
dealer and free are never in the same sentence lol
 
1 - 11 of 11 Posts
Top