Kawasaki ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Bought an abused teryx last year with a run out of oil motor. Full rebuild but skipped the valve seals as I couldnt find my spring compressor and I was tight on time. Fast forward about 20-30 hrs and it’s starts smoking a little blue smoke then gets progressively worse especially on uphill climbs it would fog out bad. Compression test was great so I figured it had to be valve seals. Break and down and change valve seals. I ran it around the yard for about 45 minutes. It still smokes But not nearly as bad and it gets better as it warms up. My guess now is maybe the rings might not have seated properly? Am I missing something obvious?
 

·
Super Moderator
Joined
·
4,690 Posts
Run it a little longer. Oil builds up in the exhaust system and you would be amazed as to how long it takes to burn off. If it never stops..yeah I would look at either sloppy valve guides...(cause even new seals won't stop then from opening up and letting oil get by).. or at least one cylinder with a ring problem. The #1 thing that wears first on these v-twins is the top end...and running hot...and out of oil means that it needed a full service...which it didn't get.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Run it a little longer. Oil builds up in the exhaust system and you would be amazed as to how long it takes to burn off. If it never stops..yeah I would look at either sloppy valve guides...(cause even new seals won't stop then from opening up and letting oil get by).. or at least one cylinder with a ring problem. The #1 thing that wears first on these v-twins is the top end...and running hot...and out of oil means that it needed a full service...which it didn't get.
Yeah I think I’m going to keep an eye out for another set of heads and do my best to not be a cheapskate. I don’t mind wrenching but i don’t have a ton of experience in these situations. So long as I learn from it anyways lol.
 
1 - 3 of 3 Posts
Top