Kawasaki ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hey guys i need some help i have a 98 mojave 250 has newer piston and rings. i was riding it the other day and it was running flawless no issues at all and i went up a steep hill and at the top of the hill it acted kinda funny like hesitant and i stopped and then it seemed to run fine when i turned around and got to the bottom of the hill it was cutting up really bad and then it just died and i couldnt get it to run again...I have no idea what is going on with it anu help would be apprciated thanks!
 

·
Registered
Joined
·
322 Posts
I would start with making sure all the wiring is alright, make sure all the connections are good.

If not that, maybe take a look at the carb and float height. Give it all a good cleaning.


Did you just buy this Mojave recently?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3 (Edited)
I would start with making sure all the wiring is alright, make sure all the connections are good.

If not that, maybe take a look at the carb and float height. Give it all a good cleaning.


Did you just buy this Mojave recently?
Yes i did just buy it recently how can u tell? lol....it doesnt have the stock carb i was told ...it doesnt look stock but it is a mikuni so i know its a good carb but when u leave the gas on after about 10 mins if it isnt running the gas pours out of the bottom nipple under the bowl so im assuming the float height is off if its doing that...how do u adjust float height? and all the wiring seems to be fine but i can check again...and it also needs a head and base gasket bad appreantly cuz they both dump oil out of the seems bad
 

·
Banned
Joined
·
11,110 Posts
Sounds like a carb problem. Float is sticking if fuel starts coming out when it's not running. Take the carb off and clean it good. Check the float. It's your problem I bet.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Sounds like a carb problem. Float is sticking if fuel starts coming out when it's not running. Take the carb off and clean it good. Check the float. It's your problem I bet.
idk I mean that makes sense but doesn't at the same time because it ran perfectly fine like that before....now all the sudden it wont even run at all?
 

·
Banned
Joined
·
11,110 Posts
When it comes to missing and cutting out 90% of the time it's a carb/fuel problem. It won't hurt to clean it one way or the other. Would be an easy task. Get it clean and the float working properly and I bet your problem will be solved.
 

·
Banned
Joined
·
11,110 Posts
No problem. Hope it works for you. I think it will.
 
1 - 8 of 8 Posts
Top