Kawasaki ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter #1
i remember the tie rod end recall,but i was told there were more recalls than that...what are they?



EDIT...i looked on the kawie website and the tie rod end recall is the only one they have listed

maybe i shoulda checked the kawie website before asking :unsure:
 

·
Registered
Joined
·
254 Posts
LOL, The 2005 had the upper A-arm spacers, that was a recall, they had a TSB on the front needle for the carb and of course the tierods and ends along with the steering compontents on some.

The 2005 and 2006 both have a Buss connector located in the main wiring harness. 1 in the front shock towers and 1 in the rear by the fuel tank vent. On the 2005 they ran + and - wires in the connector and they would develop electrolysis when exposed to moisture. On the 2006 they removed the - wires from the connector, but when exposed to moisture, the + wires would still corrode in the connector and cause problems. This was never fixed as a recall, but everyone I know of except maybe 2 or 3 people have had it fixed under warranty after developing symptoms like the fan not coming on, the 4wd not working, problems with the belt not resetting etc..... Usually just fixing the rear connector will solve all the problems.

The quads effected were the 2005 BF, 2006 BF 650i and 750i none of the SRA's were effected. On the 2007 Kawi completey did away with the connector and sealed all the wires seperate.
 

·
Registered
Joined
·
4 Posts
LOL, The 2005 had the upper A-arm spacers, that was a recall, they had a TSB on the front needle for the carb and of course the tierods and ends along with the steering compontents on some.

The 2005 and 2006 both have a Buss connector located in the main wiring harness. 1 in the front shock towers and 1 in the rear by the fuel tank vent. On the 2005 they ran + and - wires in the connector and they would develop electrolysis when exposed to moisture. On the 2006 they removed the - wires from the connector, but when exposed to moisture, the + wires would still corrode in the connector and cause problems. This was never fixed as a recall, but everyone I know of except maybe 2 or 3 people have had it fixed under warranty after developing symptoms like the fan not coming on, the 4wd not working, problems with the belt not resetting etc..... Usually just fixing the rear connector will solve all the problems.

The quads effected were the 2005 BF, 2006 BF 650i and 750i none of the SRA's were effected. On the 2007 Kawi completey did away with the connector and sealed all the wires seperate.
Hey guys, this thread is very old but hoping you could help me on my 07 750A. My bike overheats, belt light, no fan, etc. I'm looking for this connector next to the filler, but no luck...I guess they did away with it. Where do I go from here?
 

Attachments

·
Registered
Joined
·
182 Posts
buy a new harness.
 
1 - 5 of 5 Posts
Top