Kawasaki ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Has anyone had any trouble with the dynatek CDI on and 04 pairie 700 going up in smoke I was adjusting the A/F screw with the it at idle today and the bike quit running when I tried to restart it smoke started pouring from under the seat I turned the key off and removed the seat to find the dyna smoking and the plastic bubbling I unpluged it and reinstalled the stock CDI the bike runs fine what happened ?
 

·
Registered
Joined
·
9 Posts
i had my programmable dynatek crap out on me last week. the bike had stalled on me a couple times when plowing a few days before, but when i went to use it again she would not fire. took the seat off to switch back to stock cdi and instantly knew what the problem was by the rotten burnt electronics stink. the potting/sealer had came away from the case on the bottom of the unit. sent it back to dynatek so just waiting to see what they say.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Dyna is doing right by me since it is a couple of years old it is out of warranty but they said if I send the old one back they will replace it for $95 and free shipping I'm happy with that
 

·
Registered
Joined
·
2,167 Posts
I had one that was a little over a year old and out of warranty and this winter the outer case on it cracked. Not sure what caused it but Dynatek took care of it for me and didnt give me any hassle at all. Their customer service was awesome in my opinion!!
 
1 - 7 of 7 Posts
Top