Kawasaki ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
newbie to the site,love it so far..question..where is the stock fuel filter/shouldnt it have a inline filter also..oh ya ive got a 2002 650 prarie 4x4;) that might help..ive recently picked up a backfire problem..so now im learning to work on it..joy any advice will help..
 

·
Registered
Joined
·
99 Posts
i put a in line filter on my 02 praire pull your spark plugs see if they are black my o2 sat for a while had bad gas i went thu the carbs cleaned everything i also adjusted the valves the problem was my choke plungers were sticking which made me real rich my bike kept popping thru carb check your spark plugs that will show you which carb is bad i also put seafoam in gastank my o5 brute did the same thing when i let it sit without fuel stabilizer in it hope this helps ya
 

·
Registered
Joined
·
1,045 Posts
newbie to the site,love it so far..question..where is the stock fuel filter/shouldnt it have a inline filter also..oh ya ive got a 2002 650 prarie 4x4;) that might help..ive recently picked up a backfire problem..so now im learning to work on it..joy any advice will help..
Year and model?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
thanks novass..did helpme out,and reassurred what ive done so far.1st drained bowls on carbs,put seafoam in tank..then while looking i noticed boot wasnt connected to front carb on bottom.fixed that..still popping..took carb off boots and took all jets and throttle stop out and cleaned with deep creep..got back together runs alot better but sti;; has small pop..havent changed plugs again yet.but will today..didnt take carbs off because i wasnt sure about choke cable ..is it tricky..again thanks
 

·
Registered
Joined
·
3 Posts
are you sure the carb boot didn't have a tear under the strap- had that with my 06' 750- you might need to adjust your air/fuel screw, check your plug wires to make sure those aren't split either. did you check/change your oil? go through water before the problem started? where in Ohio are you
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
getting better

not 4 sure but will check next time carbs r off..might spray to see if it leaking..no..when whoever had them off last,put them back on ,they had the clamp part located where the carbs wouldnt/couldnt come down far enough.or maybe it just vibrated out /who no's..im in preble county/sw ohio..u..also oil level is fine //needs changed baad..just got filter.havent had it in any water/mostly utility use..actually i bought it with this popping..guy told me he had it looked at and they told him it was plugs..he had plugs but just (said) he hadnt had the time to change im..poppin got worse..i changed the plugs..still popping/the got worse/then lost power..i think im on the right track with carb


thanks 4 info..
 

·
Registered
Joined
·
99 Posts
on the choke plungers take them out clean them real goodyou can strech the springs some on the plungers i did that to my 05 brute a year ago and they are still good. i orderd new choke cables for my 650 praire when i had it they were a different part number i think they were a little bit longer.check with your dealer.i sold my 02 a couple of tears ago its still fine
 
1 - 7 of 7 Posts
Top