Kawasaki ATV Forum banner

1 - 20 of 53 Posts

·
Registered
Joined
·
1,998 Posts
Discussion Starter #1
Just like the title says John. Good Luck its been a long time coming for this and I'm ready to see what this AMR kit built by VFORCEJOHN does on the dyno..... 800 kit EFI. I'll be waiting for the good news. Glad it already had your clutch done to it:rock::yeehawi::cheers:
 

·
Registered
Joined
·
2,583 Posts
Good luck How much breakin did you do? Been thinking about a dyno tune in phoenix on mine next week if its together. Way to cold and snowy to ride much where I live. Would like to get 10 hrs on it before I go down however.
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #5 (Edited)
Ohh boy, I still didn't get the PC3 they were supposed to 2 day it Last thursday with the ignition module, Got that Saturday, Well they didn't even ship it until Monday and they fuckking shipped it UPS ground when I paid 15.00 extra for 2 day priority.

It'll be here Monday the 14th. :(

I just can't win when it comes to your brute
Thanks John. That sucks another set back. Nothing new. Not one of them was your fault I know that.
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #7

·
Registered
Joined
·
477 Posts
That's sucks seems like 1 set back after another.
 

·
Registered
Joined
·
2,583 Posts
Well whats taking so long :lol:
Me being a dumbass not knowing I needed stock retainers for kibblewhite springs. All I had was the R&D retainers.
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #11
Yeah John should get it in the mail tomorrow and be on the dyno some time this week.
 

·
Vendor
Joined
·
15,419 Posts
...still going. with the EHS lid, injector duty is 90%. I have larger injectors. (thank god I don't have to order them :lol:) when things cool down, I'll swap them. it's a good hour job.

so far it still stumbles out of the hole a/f is dead on perfect. something in the ECM is cutting back timing or something. I tried the vacuum canister on the map sensor. it helped low end a little but not a direct fix. I tried crossing the intakes. mini ms mod on the vacuum nipples under the intake flange. that did nothing. I also crossed the larger IAC sensor lines. that helped a little but still not enough to be consistant. That is this things main problem. getting a consistant run and keeping it there

I have 4 kawy map sensors, they all do the same thing. so it's nothing faulty. funny thing is, I can sit the map sensor on my lap with a longer vacuum signal hose to the head. blow in the sensor with just breath (like you are blowing out a candle) and it'll run better. a/f changes richer, but from 12.5-12.6 to 12.1-12.3 I can up the a/f with the pc3 to 12.1-12.3 and it runs worse. seems to like 12.5-12.8 range for max power.

Ignition module is on and timing is +10. maxxed out. past 7000 rpm I dial it back to 8 and then 6. runs the best like that.

pc3 fuel pump enrichener is on actually I dial back the fuel not enrichen it and power came up low end. so that's done

FI on these BBK bikes is a waste. if this thing was carbed. it'd be 68-70 rwhp easily. that motor is strong as hell.

If you roll on it at 20, power is 62 rwhp @ about 50 mph and keeps climbing . gun it out of the hole and something restricts it. You can immediatly hear it/feel it something happens, it only makes 57-59 rwhp and falls flat on mid-top.

with out the pc3. 42 rwhp. it won't even run just stumbles, but still blows 14.5 a/f

back to tinkering. it should be cool enough now to put the injectors in. I'm also going to flow skips stock injectors. I'd bet the rear injector flows less than the front. exhaust temps are near 80-100 degres higher. front runs 675 rear is 750-775 could be related to the bends of the muzzy pro. upping the cylinder split feature 5% will make them very close in temps.

and The new rings Glenn sent me are about the best I've ever had in one of these motors. there is ZERO blow by even holding it at 80 mph. not even so much as a puff of air or oil.

the 1 layer head gaskets are holding nicely, no issues there either.

back to work

John
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #15
Thanks for the update John I'm starting a new thread.
 

·
Registered
Joined
·
2,583 Posts
Looks like you have a long night ahead John.
 

·
Registered
Joined
·
1,998 Posts
Discussion Starter #18

·
Registered
Joined
·
1,998 Posts
Discussion Starter #20
1 - 20 of 53 Posts
Top