Kawasaki ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1 (Edited)
Hello everyone. New here and still learning. I bought a non running KFX from a guy in Alabama. Traversed it to Georgia and found out why it didn't run 1500$ later. Here is a picture of me doing the finL touches to the engine.
It has now Hot rods and crank. New tensioners and chains. Also new flywheel, starter drive, sprag, pistons, valves and springs. Many other odds and ends as well.
Hope to learn a lot here.
I've been looking and there are some other things I would like to try, spring for clutch, advance key, and such.
Right now it cranks over and runs but doesn't go "fast". It kind of platues at around 4500(just a guess). Carbs are jetted and clean. The exhaust is after market and i hate the sound be it will so for now. The exhaust may sound like junk due to possible suspected ignition related issues.
I worked on cars/trucks and heavy equipment for quite some time then got tired and decided to become a fire fighter and keep the cars as a hobby.

Well I guess I'll be talking to ya guys.
Thank you.
 

Attachments

·
Registered
Joined
·
20 Posts
Discussion Starter #4
So I took apart the carbs again and found my emulsion tubes were clogged. I got out the small torch and heated them red, it cleaned them right up. Installed them and is a little bit better. It acts like it needed more fuel. So I just kept going up sizes and now I'm at 170 front and rear. Pilots at 42.
It still acts like it wants more fuel..is it normal for these things to be guzzlers. I have stock cams and flat pistons. Cant imagin these using so much fuel.. oh well over the weekend I'll try some bigger jets maybe some 175.
 
1 - 4 of 4 Posts
Top