Kawasaki ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Alright, when I drive my kfx wide open for about 30 seconds it wants to cut out but if you let off it will drive normal again (it's like the bowl is running out of gas). Or if I ride it hard around the trails it will sputter, bog and die. It will start back up again, but only with the choke. It's like if you run it hard it's running out of gas but the fuel delivery to the carb is normal. I took out all the jets and cleaned them, checked to make sure fuel is running well out of the petcock, and the tank is breathing normal too. I cannot figure this one out! Oh ya, and there is a brand new spark plug in there too.. Anyone ideas what would be wrong please share. Thanks
 

·
Registered
Joined
·
447 Posts
How did you test fuel delivery? The vacuum petcocks on the Z's sometimes fail. Try the RES position and PRI position. See if it improves. Did you remove the petcock from the tank and make sure the filters are not plugged?
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
I just removed the hose from the carb and let it flow and it came out fast and didnt seem like it was plugged.. I have already tried pri and res and they didnt do any better.
 

·
Registered
Joined
·
447 Posts
If you're sure the fuel is getting to the carb, have you check the float height and needle on the float? It only takes a tiny bit of junk to plug that jet.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
ya i've taken the floats and needle and seat out and sparyed it all down with carb cleaner. what do you mean by that jet... i've taken the three jets out and cleaned them too
 
1 - 6 of 6 Posts
Top