Kawasaki ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
I bought this 04 KFX 2 weeks ago and all has been fine until tonight. Got it out and ran about 20 minutes then died. I have power at the dash , but no head lights and it won't turn over. Battery is hot. I checked both the round fuse and the 30 amp with a meter they are good. I am leaning toward the roll over or the relays by the rectifier. Any help would be greatly appreciated.
 

·
Registered
Joined
·
8,150 Posts
Have you tried crossing the solenoid to see if it cranks that way?

Tap the rollover sensor while holding the start button to see if that does anything for you.

I have lots of OEM parts here if you want to go down that route let me know, I can hook you up for cheap
 

·
Registered
Joined
·
45 Posts
Def check soleinoid...happens to me all the time just tap it or cross ove the 2 bolts on top with a wrench or screwdriver
 

·
Registered
Joined
·
41 Posts
Discussion Starter #4
I jumped the solienoid , it turns over but it is not firing. I did notice on of the relays was somewhat warm to touch when I pulled it out. Like I said I also lost head lights. The fuel pump is running and the dash lights come on just no ignition. I would jump the roll over switch if I knew which one to go from and too. I am ready to get it fixed , my neighbors are giving me greif , the have a 700XX
 

·
Registered
Joined
·
8,150 Posts
I'm not sure you can jump the rollover switch..You can take it out and set it on its top to see if it changes anything.

I haven't come across one of them going bad yet, usually the starter relay. Just changed one a few days ago
 
1 - 6 of 6 Posts
Top