Kawasaki ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
A bit of a long shot this , i have recently aquired a road registered KFX 700 with a few electrical problems ,most of which are now sorted [ previous owner had a bored german shepherd ..!!] this machine has [ or had and bits of ] indicators fitted which do not work , traced the the harness down to the headstock found a multipin plug and 2 other leads hanging in the breeze , not too sure if the plug is correct as most flashers tend to be 2 pin only .

As this is a euro machine [ and wiring and parts diagrams only show us versions ..!!!] i,m not sure what should fit it to enable me to get them sorted and usable again as i need them to work for an upcoming inspection to get the animal back on the road .

Just thought i would try the forum to see if anyone else has any pearls of wisdom otherwise i will have to ring a main dealer in the UK tomorrow and try and pick their brains ..!!
 

·
Registered
Joined
·
29 Posts
Discussion Starter #2
Digging into this machine a little deeper ,i have found that this an aftermarket kit by a Spanish company Leonelli Spa who i have never heard of who make loads of bike , and vehicle control gear , so have contacted them and we will see how we get on ..!!
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
Well suprise no reply, still it is Spain every thing closes down for a month /6weeks for vacation ..!! So its out with the meter and try to follow the cables , why does every manufacturer get so mean with cable ...!!!

Well they are now sorted and as i was on the crest of a wave i thought i will be brave and fit the Acewell 5000 series instrument panel i bought new a few mths back , this i got from a racecar builder who had to many for some of his projects ,so he sold off the surplus as he didn't need this particular model anymore , i had already got a mounting bracket and wheel sensor from racetech [ UK importer ] i then had to find an additional mount to mount the bracket to ...!!!

I went to a local chinese warehouse [ we have loads of them in Spain ] looking for inspiration , i ended up with a stainless steel "y" shaped over the door hanger which i straightened out ,drilled and mounted in the top of the steering head using the 2 threaded holes conveniently provided by Kawasaki.
Then the fun started with the cables and sensors , as this a fully specced instrument it had loads of facilities that i already have on the machine and i have wired some of them in so i have info on the indicator panel and on the Acewell ,the rest are redundant so i am at the moment tidying them up and tucking them up behind the steering head, ,taken around 6 hrs so far [ its 36c at the moment ..!!].

Just waiting for some s/s "p"clamps from the UK [ not available in Spain ..!!] to mount the speed sensor to the front hub ..
 
1 - 3 of 3 Posts
Top