Kawasaki ATV Forum banner

Have you experienced an oil leak of a seal behind the water pump impeller - Prairie?

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
I was disappointed when the dealer told me the '04 Prairie 700 I just bought used has an oil seal gone bad behind the water pump impeller - says it's common for overfills at oil change - costs big repair bills to fix - gotta take lots of bits apart....

Anybody else experience this?

I'm new to the list - any experience appreciated....
 

·
Premium Member
Joined
·
16,645 Posts
Why does he think it need to be replaced?
It's not a common problem and it's not a hard job to do,maybe we could walk you through the repiar.
 

·
Registered
Joined
·
15,419 Posts
It's as easy as installing a degree key.

remove the stator cover side. (you don't even have to pull the flywheel). tap out the seal. put a new one in. about a 2-3 hour job. turning the atv on the side you don't even have to drain the oil.

Just curious as to what they said it would cost. for me to do something like that you would be looking about 150 in labor plus gaskets, oil and antifreeze.

John
 

·
Premium Member
Joined
·
2,401 Posts
thats a stealer for ya. a deg key takes alittle more effort as you remove the flywheel. other then that its easy to fix, but i never had one leak yet. but replaced it when i put my 6 deg key in.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top