Kawasaki ATV Forum banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
1,635 Posts
Discussion Starter · #1 ·
I seem to remember that on the turbo bike the sending unit for your oil pressure gauge was screwed directly into the case, but on Lucky Lime it looks like you used a braided line to remote mount it. Any reason why? Thanks.
 

·
Premium Member
Joined
·
1,689 Posts
Not to jump in, I read his recent build of Kawigirls V, He stated something about it getting dammaged eazy. Thats what I recall on the remote Idea. I am thinking of adding a pressure gauge also and am interested in camo response as well.

Camo, can you use the stock sending unit onto an after market gauge?
 

·
Premium Member
Joined
·
1,635 Posts
Discussion Starter · #3 ·
The remote mount does seem a lot safer. Wonder what thread size the hole in the case is?
 

·
Premium Member
Joined
·
757 Posts
The hole in the case seems to be 1/8" pipe.
I'm not sure if it's NPT or BSPT but I used a 1/8" NPT tap to open up the hole a little so I could use a 1/8" NPT tee so I could run a mech. gauge and keep the sending unit for the idiot light.
Here's some good info I refer to: McMaster-Carr
 

·
Registered
Joined
·
3,845 Posts
This is interesting info here. Anyone have a picture of there oil gauge setup? What oil gauge is best to use? And what is normal oil PSI with a std bore kit?
 

·
Premium Member
Joined
·
757 Posts
manual says 69.7psi @ 4500rpm & 230*F oil temp.
I'll take pics if you want later...right now everythings under 6" of snow....and it's still coming down!!!!
 

·
Premium Member
Joined
·
757 Posts
I unscrewed the stock sending unit...
ran a 1/8" NPT tap in a little...
screwed in the tee I LINKED @ the bottom and reinstalled the stock sending unit...
leaving the open female hole facing forward...
then got a standard Stewart Warner 80psi mechanical oil pressure gauge @ napa and installed it as per the instructions...

LINK:
McMaster-Carr
 
1 - 8 of 8 Posts
Top