Kawasaki ATV Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
I just snorkeled my air box, what a pain that was. Starts and idles fine, but bogs down on top end ! Snorkel is 2” . Stock exhaust, and jets, foam filter..
what’s my next step ? I’m a complete idiot when it comes carburetors.
Tire Plant Wheel Window Automotive tire
 

·
Registered
Joined
·
818 Posts
efi or carb?

if carb use the choke to richen it when running to see if the bog changes.

worse to rich.
better to lean stays the same ??
put in new plugs
run it till it bogs.
pull plugs and see if black or little green specs on the white porcelain of the plugs.

you may have to rejet
 

·
Registered
Joined
·
277 Posts
I farted around with my 700 Prairie and simply removed the intake cover which made it run like xxxx. You thought the snorkle install was a PITA? Ha, wait till you have to get to the carbs half a dozen times to jet it right. Its probably to lean now. Like Auburn said, clean the plugs or replace. Do a few speed runs in the bad running area, shut it down immediately after the run(no idling around) and pull a plug to see what it looks like. Black and sooty is rich and whitish ashy means to lean and report back. Remember 0 to 1/8 throttle is the pilot circuit, 1/8 up to 3/4 is the needle setting and these are not clipped for adjustment,must use washer type shimming and WFO is the main circuit basically.
 

·
Registered
Joined
·
3,548 Posts
Probably need a bigger intake snorkel size - The brute 650 / 750 air intake opening is a little bigger than 2 1/4". So a 2 1/2" snorkel would work great - Not sure what size intake the 700 has ?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
Update, still have carb issues from snorkels. Been waiting on my carb guy to get to it. He’s been busy. So I’ve just been finishing up my little upgrades. Got all my snorkels 2” copper. Air box intake is 11/2” so 2” is plenty. Been riding around the neighborhood at cruising speed, still bogs out on top end. I’m getting impatient, wanna hit the mud. I pulled my plugs, heavy black soot on them. Running rich. Pulled my air box cover and it runs perfect, no bogging down. I’ve located my screws , just scared to mess with them. Carbs is not my thing. Should I do it ??? Or wait for my carb guy. Got a big new year’s run I wanna make.
Motor vehicle Automotive tire Gas Automotive wheel system Auto part
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top