Kawasaki ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
247 Posts
Discussion Starter #1
My Brutes battery has died :mad:
Does anybody know of a replacement battery for the KMX14BS?
 

·
Registered
Joined
·
787 Posts
Died? I have had mine for three years, and is still going strong. Is yours the Yuasa battery, because you might want to tell your dealer if it is bad, because your bike was bought this year.
 

·
Registered
Joined
·
247 Posts
Discussion Starter #3 (Edited)
Not the battery after all,worse problem..

Ya it's a Yuasa and it actually checked out fine,meter went on the fritz:mad:
So i think iv'e got a bad wire or connection happening.Pulled all my plastic and went over every plug and wire with a fine tooth comb.Nothing!(all connections have dielectric grease) the only thing left i can think about is...about a week ago when i shut off my bike i turned off the headlights after that and heard a clicking noise coming from the front of the bike.(I normally leave the switch in the on pos.) as i ride with the lights on.If i put the switch in the on pos. while the bike is off it stops.Maybe something in the light switch is hooped? the lights are working properly:huh:
Is there any thing eles i could check that might be drawing current while the machine is off? Thanks guy's ....I'm stumped
**I don't want to take it to the stealer even though it's under warranty cause my dealer's mechanic is an idiot! Seriously!
 

·
Registered
Joined
·
787 Posts
I've had the belt actuator go bad and continue to draw after I shut the bike off.
 
1 - 4 of 4 Posts
Top