Kawasaki ATV Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Im confused and baffled at this problem! It was sitting for like 2yrs, when I got it, but I did hear it running. I never rode just took it home and had the carbs cleaned and jetted, got new fuel filter and new pump because the other pump was bad, air filter, fresh antifreeze, oil and filter change, plugs.
:confused::confused::confused::confused::confused::confused::confused:
Now I have it all back together and it wont stay on.
as soon as I turn key to on position and crank it it turns on and 3 seconds later it shuts off. The only way it will stay on is if I constantly cycle the key to OFF & back to ON as it about to die and it seems like it resets something for 3 seconds and back to KEYY OFF & ON! I replaced the CDI box and tilt switch and its still doing the exact same thing
:confused::confused::confused::confused::confused::confused::confused:
can someone pls help me I would like to ride before it gets cold.
 

·
Registered
Joined
·
4,802 Posts
role over sensor guaranteed.
 

·
Registered
Joined
·
1,036 Posts
Definitely sounds like the roll over sensor.

Its located under the seat at the end of the battery.
Has 3 or so wires coming out of it, little black box looking deal.
 

·
Super Moderator
Joined
·
12,536 Posts
Or the ignition switch itself.
 

·
Super Moderator
Joined
·
12,536 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #8

·
Super Moderator
Joined
·
12,536 Posts
I replaced the CDI box and tilt switch and its still doing the exact same thing
.
Or the ignition switch itself.
Are you saying you have already changed the rollover sensor?
Does it still have the original stock ignition (key) switch?
Yes I did with a used one. I orded a new one.
So the used rollover sensor is also doing the same thing? Hmmmm....
The key switch needs to put out 5v, same as the rollover sensor, or it will also do the run/stop thing.
 

·
Registered
Joined
·
5 Posts
I have a 2004 700 Kawasaki kfx it starts and dies after 3seconds I checked the role over sencer put a new key switch on it and New fuel pump still have the same problem any ideals what else it could be
 

·
Registered
Joined
·
5 Posts
Yes And my back cylinder quit fireing I put another coil on the back cylinder still no fire And it still runs 3 second's and dies
 

·
Registered
Joined
·
541 Posts
do you have a cdi to borrow from someone?
you may also check you
 

·
Super Moderator
Joined
·
12,536 Posts
Did you put a genuine Kawasaki key switch assembly on it? How do you know the rollover sensor is working?
 
1 - 19 of 19 Posts
Top