Kawasaki ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 · (Edited)
EBC help - 03 Prairie 650

Hi Folks, new owner here. I recently acquired an 03 Prairie 650 from my Mom. Is is for snow plowing duties. The battery was dead so I proceeded to charge it. When I reinstalled the battery, after turning off the key switch, it makes a loud buzzing sound continuously for a few seconds. Then it begins a chriping noise every few seconds. Both sound like they are coming from what I believe is the starter solenoid? It is located on the right side down by your foot. It continues to make this chrip infinitely until I disconnect the battery again. I'm sure this cannot be normal. Any ideas? Is the starter hosed? Is it even the starter that I am referring to?

Also does anyone have the service manual in PDF format?

Thx
 

·
Registered
Joined
·
1,038 Posts
sounds like its the engine brake control module located on the belt cover.

they make noise after you shut the key off, but it should quit after a few seconds.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #3 · (Edited)
sounds like its the engine brake control module located on the belt cover.

they make noise after you shut the key off, but it should quit after a few seconds.
That is probably what it is. Here is a picture. But it does not stop after the key is shut off. It makes a long (2-4 seconds) noise right after I shut the key off but then it keeps chirping twice every few seconds. (which I'm guessing why the battery used to go dead all the time on them??)

 

·
Premium Member
Joined
·
1,377 Posts
Before you go out and buy a new KEBC(engine brake controller), try this 1st.
With key "OFF", clean the fuse holder(under seat). Remove the CVT cover and clean the KEBC, also check the belt area for any excessive dirt/dust, blow out with air, reinstall cvt cover. (Be sure the Belt lever inside the CVT cover stays in the "ON" position when you reinstall the CVT Cover)
Disconnect the KEBC plug connector, clean, replug.
If it still chrips after the 2-4 seconds with turning the Key off, then you may have a faulty KEBC unit(this was a common problem on the early yrs of the P650's). Get the part # and search online stores including ebay for the lowest price, you may even be able to find a perfectly good used unit at a decent price.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #5 · (Edited)
Thanks. Also the "Belt" light on the dash blinks while the ignition is on. Does it need a new belt?

After trying the above suggestions, it still makes the noises. Will it hurt if I run it without the ebc fuse in? Will that affect the performance of the machine without that fuse? It seems to spit, sputter and back fire but the battery is also shot. Wondering if a new battery would cure that.
 
1 - 6 of 6 Posts
Top