Kawasaki ATV Forum banner

1 - 20 of 59 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
Welp the motor is nomore!! Ill disclose more info after i talk to ray in the morning to see what we can do! At least i got to make 3 races at the dirt track and i think i went to 4 races on asphalt! She lasted prolly 8 to 10 hrs run time!!:confused:cid:FE9EB8AF-2390-4FF0-86BE-6E346F7D615B/Brian%25202.jpg
 

·
Premium Member
Joined
·
23,817 Posts
well that sucks

hope it don't take as long to fix it as it did to get it

need to try and get it ready for March
 

·
Premium Member
Joined
·
22,490 Posts
That's too bad BWilly. :( You haven't talked to Ray yet? :hmm:

I'm sure he'll look after you.

Now we'll just sit back and wait for the 2 or 3 vultures to show up.
 

·
Premium Member
Joined
·
23,817 Posts
That's too bad BWilly. :( You haven't talked to Ray yet? :hmm:
I'm sure he'll look after you. Now we'll just sit back and wait for the 2 or 3 vultures to show up.
:confused:

I'm sure Ray will do whatever it takes to get you going again Brian. Probably nothing serious. Always have him swap you out for a good one if that ones really toast.
 

·
Registered
Joined
·
2,583 Posts
That sucks man. "fuked up beyond all repair," is not good. Hope it all works out.
 

·
Registered
Joined
·
142 Posts
Discussion Starter #9
talked to ray earlier, He is gonna try and do all he can to help me! Here's what happened, One intake valve broke off the stem where it starts to mushroom out. and it took two chunks out of my piston and nicked the head up, and knocked the valve and seat out of one of my exhaust valves. basically it was just valve failure.
 

·
Premium Member
Joined
·
9,455 Posts
Damn that stinks

But when you push the limits like a lot of us are doing now some failures are to be expected

Sorry to hear about it though

Glad Ray is going to do what he can to get it back up and running
 

·
Super Moderator
Joined
·
9,447 Posts
What brand valves? Kibblewhite?
 

·
Registered
Joined
·
7,254 Posts
Yes those are kibblewhite valves. We'll know more when we get everything here. Brian had just changed cams so it's possible something was wrong with the cam and let the valve hit the piston????
Ray
 

·
Registered
Joined
·
6,016 Posts
hope it works out soon for ya man.at least by march i wanna see that thing run.
 

·
Premium Member
Joined
·
16,646 Posts
That sucks...
It can happen to any builder,chit happens when the limits are trying to be pushed to a higher level.
I hope it all works out in the end.
 

·
Premium Member
Joined
·
23,817 Posts
Yes those are kibblewhite valves. We'll know more when we get everything here. Brian had just changed cams so it's possible something was wrong with the cam and let the valve hit the piston????
Ray
huh :confused: something wrong with cam :confused:

either to much lift or duration, wouldn't that be what happened. Doesn't sound like something wrong with the cams, that sounds like some big cams....are you holding out on everyone Ray, on some of the new Ultimate Wanna Slap yo Momma cams:D Just sounds like they were to big for the clearances already there or to much for the valve train
 

·
Premium Member
Joined
·
22,490 Posts

·
Premium Member
Joined
·
6,975 Posts
:lol: SPANK THE MONKEY CAMS :lol:

Sucks how one little part can do that much damage. It could have been worse... I could have been a bottom end issue.
 

·
Vendor
Joined
·
15,419 Posts
Damn, that sucks, but you got to expect things like this to happen with pushing it that far.

BE SURE TO CHECK THE CRANK BEARINGS!!!!

I had a motor I went and replaced heads on from a severe valve cylinder failure and the crank spun out of it. apparently from the piston hitting the valve/head it damaged the crank bearing but the rods were still moving nice and free with noside-sideplay.

it's worth the 30.00.


Did he install the big FCP cams??

John
 
1 - 20 of 59 Posts
Top