Kawasaki ATV Forum banner

2801 - 2817 of 2817 Posts

·
Registered
Joined
·
448 Posts
After a top end rebuild, I got the engine reinstalled, clutches rebuilt and reinstalled, receiver hitch and drop hitch built and installed, rear winch mount built and installed, and bought back the walking beam trailer I built and sold years ago. Gotta go break in that engine and I’ll be good to go!!
View attachment 74630
 

·
Registered
Joined
·
448 Posts
74631
 

·
Registered
Joined
·
3,135 Posts
Installed my new used BF750 clutches. Before I installed them, I completely disassembled them, checked everything out, polished the pins, deglazed the sheaves, cleaned the weights, and blew out all the crud. Then I threw on a new belt, and set the deflection. Tore the secondary apart and removed the thinnest shim, then put it all back together and installed again. Perfecto. Went for a little rip. Wow, new clutches are NICE and quiet. Forgot how smooth things can be when everything is happy.
Still can't believe I found 13 year old clutches with only 600 miles on them!:cool:(y)
 

·
Registered
Joined
·
3,135 Posts
Went for a ride out in the west desert today so I could really check out these clutches. Forgot to mention in my last post that I left the stock bf750 springs in. Well, holy bat crap, I think I just found the magic combo for this engine! The old Prairie flipping loves them! The midrange is insane. Off the line is still good, though maybe just a tad less violent. Top speed picked up about 5 mph. Backshift is perfect (at least for my current tires).
I have been suspecting for several years that my epi almond secondary was pinch-binding, and it appears it was sometimes. The paint is nearly completely gone on it.
Anyway, it ain't going back in. The Brute springs are staying in for awhile.;):cool:
 

·
Registered
Joined
·
14 Posts
Got my workbench and tools organized and will re-assemble carbs for my 650 Prairie tomorrow and hopefully have everything back together and running soon.
 

·
Registered
Joined
·
3,135 Posts
Put some new shoes on the old girl. My old set was only half wore out, but a friend of mine wanted them because he was sick of riding around on bias ply tires. So I got my third set of these maxxis viprs.
 

·
Registered
Joined
·
448 Posts
New skins are always good. Did the same thing myself to my old Brute. Got rid of my Mud Lite XTR's and put on a set of Interco Swamp Lites. While I had the tires off I replaced the front brake pads too. Got a really good deal on one of those pre black friday sales on the Swamp Lites.
 

·
Registered
Joined
·
2,771 Posts


Nothing. But I do have to-do list.
 

·
Registered
Joined
·
2,771 Posts


Back in Oct I did put my winter tires back on. Carlisle Mud Wolfs on 2008 OE wheels.


This is the Brute Force that donated its wheels.
 

·
Registered
Joined
·
2,771 Posts
Does it have a stock exhaust it wants to donate to me ? Hehe
It went back to Kawasaki back in 2008.

My friend didn't take the aftermarket wheels and tires off before he sent it back.
And I'm glad that he didn't. I hate offset wheels. ;)
 

·
Registered
Joined
·
2,771 Posts


I change my oil and filters today along with the front differential oil.



10,000 miles and spotless.



I love these $2.96 OE air filters. :love:



I also did my annual belt replacement.



The old belt didn't really look all that bad.
I guess with only 1158 miles on it shouldn't be junk. :LOL::ROFLMAO:




I put my recovery hook back on too.
You never know who's going to try and follow you. ;)



I am once again trail ready.
 

·
Registered
Joined
·
702 Posts
Got the new Bison bumper put on I like it alot more then the Moose bumper. I dont think they are making Moose front and rear bumper anymore. Also changed the oil had 450 miles on it.


74779
74780
 

·
Registered
Joined
·
3,135 Posts
🤯🤪😎
I did this to my Kawie today:

Missed the mark by one mile! Lol!🤬
 
2801 - 2817 of 2817 Posts
Top