Kawasaki ATV Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1,413 Posts
Discussion Starter · #1 ·
Brute started acting up again while I was riding it today. It would slowly start to lose more and more power, eventually getting to the point where it wouldn't accelerate over 25. I checked fuel pressure it was about 35-37. Book says 43 I think. I'm guessing this is too low.... I tried cleaning the pressure regulator by blowing it out but it didn't help.
 

·
Registered
Joined
·
652 Posts
my fuel pump was BAD and still put out 43 psi...took the dealer 8 hours to troubleshoot until they put a new pump in...2500 miles later...still awesome!
 

·
Registered
Joined
·
1,413 Posts
Discussion Starter · #4 ·
The internal filter was probably dirty..., and im sure as hell not paying $600 for a new pump
 

·
Registered
Joined
·
652 Posts
The internal filter was probably dirty..., and im sure as hell not paying $600 for a new pump
Trust me - I spent hours on it myself before bringing it in even though it was under warranty. If I can do it myself- I at least try. Anyway- I did clean the internal filter inside the pump etc...here's the thread with a lot more detail. You have the exact symptoms that I had...sucks that there's not an aftermarket fuel pump. I think someone found a $100 pump that works for the King Quad. Good luck and let us know how it goes!
Nyroc's ATV info website problem
 

·
Registered
Joined
·
1,413 Posts
Discussion Starter · #6 ·
You cleaned the fuel sock not the filter. There is a filter in the top of the fuel pump housing
 

·
Registered
Joined
·
1,413 Posts
Discussion Starter · #7 ·
Well, I will have to solve the problem soon, I have a hatfield mccoy trip in 2 weeks...
 

·
Registered
Joined
·
652 Posts
You cleaned the fuel sock not the filter. There is a filter in the top of the fuel pump housing
Does anyone have a breakdown diagram of the pump? I had the thing completely apart and all I saw was the sock then. Gotta ask- did your clean your filter then? if so did it help?
I've used a Mr. Funnel filter and a profill filter sock deal since the new fuel pump.
 

·
Registered
Joined
·
1,413 Posts
Discussion Starter · #9 ·
I used a pick to rip it out. It ran awesome afterward, never better. But this is probably part of my issue, no filter between the pump and the regulator. Piece of garbage in the regulator and I can't get it clean enough.
 

·
Registered
Joined
·
1,413 Posts
Discussion Starter · #10 ·
I think I have a plan... I will start working on it tomorrow.... It includes buying no Kawasaki parts...
 

·
Registered
Joined
·
1,413 Posts
Discussion Starter · #11 ·
I just bought a corvette fuel pump, some fuel fittings, some material to make a bracket, and ordered a universal fuel pressure regulator...
 
1 - 11 of 11 Posts
Top