Kawasaki ATV Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
112 Posts
Thats me. With your old Carbs
 

·
Registered
Joined
·
786 Posts
Discussion Starter · #3 ·
u still running those carbs.
 

·
Registered
Joined
·
1,934 Posts
hey i cant see the dyno numbers on my phone what are they?
 

·
Super Moderator
Joined
·
9,448 Posts
Interesting vid. Where was this Dyno done? In Oklahoma?

Just curious...I don't understand why the dyno runs were so short. Seems like he only stayed on the throttle for 3 seconds on each run. Is that normal??? Whenever I've had my Prairies on the dyno (3 different times), we usually hold the throttle down much longer than 3 seconds.

Happy trails...:)
 

·
Registered
Joined
·
112 Posts
Yes still running them. Seem to work pretty good. The runs were longer than 3 seconds, we went to redline. Yes its in Tulsa. As for the clutch tired and tried not really sure what to do.
 

·
Premium Member
Joined
·
11,525 Posts
Looks like there was no load on the dyno.
 

·
Premium Member
Joined
·
757 Posts
That's what I thought too PIPO...
and I've never even seen Dyno in person...
 

·
Registered
Joined
·
1,934 Posts
what were the numbers?
 

·
Registered
Joined
·
1,934 Posts
is that good for a large bore with ported heads? im basing this off of what was accomplished with bwoodys 730
 

·
Premium Member
Joined
·
16,645 Posts
Yes still running them. Seem to work pretty good. The runs were longer than 3 seconds, we went to redline. Yes its in Tulsa. As for the clutch tired and tried not really sure what to do.
Are you running the clutch setup listed in your sig?
 

·
Registered
Joined
·
930 Posts
is that good for a large bore with ported heads? im basing this off of what was accomplished with bwoodys 730
My 785 pulled 68.28 RWHP straight line on motor & 106 RWHP straight line going up till I let off on 40 shot of NOS
 

·
Registered
Joined
·
112 Posts
Yes still running them. Seem to work pretty good. The runs were longer than 3 seconds, we went to redline. Yes its in Tulsa. As for the clutch tired and tried not really sure what to do.
Are you running the clutch setup listed in your sig?
Yes. But I plan to try a O/B spring this weekend.
 
1 - 18 of 18 Posts
Top